Archive for February, 2010

Videos of the hybrid kit working

Hey the videos are finally up.  The first one is a look at the two new driving modes added to the cart.  The first half of the video is hybrid mode.  In this mode the electric motor and gas engine are running together.  The second half shows just the electric motor running the cart.

After we fired it up we gave it a few test runs before hitting the street.

Advertisements

Leave a comment »

New section coming soon!

We are going to add a new section with our reports and presentations so you guys can see what we’ve done outside of the builds.  Look forward to it.

-Anthony

Leave a comment »

New State of Charge Indicator

Check this gadget out.  This screen tells us our speed, our battery life and regen percentage among other things.  It even lights up for low light driving.

We will be designing a sleek dash mount to integrate the toggle switch and display.

-Anthony

Leave a comment »

Belt Tensioner Revisited

We were having difficulties earlier trying to mount the belt tensioner to the plate.  We finally were able to get it to work.  We then went and bought a 45 inch AX belt.  The complete setup can be seen below.

Here is a picture of it installed in the cart.

Leave a comment »

IT WORKS!!!

We finished installing the kit today and gave it a test run.  It all works.  We just need to tweak a few settings and then we will be ready for our performance tests.  Videos and pictures posted soon.

Leave a comment »

Big Day Tomorrow

We have most of our components installed.  We just have to mount the throttle cable and install the tensioner.  Then we will need to find a belt that fits.  After all of that, we should have the electric drive system working!

-Anthony

Leave a comment »

New Pictures Up On Flickr!

We added new pictures on our photostream.  Check them out!  Just click on them in the sidebar.

-Anthony

Leave a comment »